Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 20, 2026 - 03:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 14, 2026 - 12:11 UTC
Scheduled
Cloud services on eu.ciscoiot.com will be updated during this maintenance window.
Services Affected
Secure Equipment Access
Customer Impact
During this maintenance, Management VPN Tunnels may be disconnected and will reconnect. Cisco will continue to monitor and validate the services throughout the maintenance window.
While we expect this maintenance to be seamless for all, users may experience brief interruptions for the following features:
- Secure equipment access sessions
Features targeted for this release Secure Equipment Access (SEA) - User Account expiration feature enhancement to provide unlimited expiration time option for all SEA roles.
Posted Jan 14, 2026 - 12:10 UTC
This scheduled maintenance affected: EU (Secure Equipment Access Service).