EU Organization Hierarchy Service Investigating

Incident Report for Cisco IoT

Resolved

Org Hierarchy component has been decommissioned, closing this incident.
Posted Jul 13, 2026 - 09:11 UTC

Update

Org Hierarchy component has been decommissioned, closing this incident.
Posted Jul 13, 2026 - 08:50 UTC

Investigating

A partial outage was identified for Organization Hierarchy Service in EU. We are investigating.
Posted Jul 13, 2026 - 08:29 UTC